seriously, sorry... tried to ctrl+c that but didnt get in time
authorgnychis <gnychis@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 17 Jan 2009 04:42:26 +0000 (04:42 +0000)
committergnychis <gnychis@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 17 Jan 2009 04:42:26 +0000 (04:42 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@10249 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-core/src/lib/general/gr_clock_recovery_mm_ff.cc
mblock/src/lib/mb_message.cc
usrp/host/lib/inband/Makefile.am
usrp/host/lib/inband/usrp_usb_interface.cc

index dd46bbea4795f711fd3b6936f9b0912b415f614a..fdf82667ae572b59772829c7374db8292621723a 100644 (file)
@@ -130,7 +130,7 @@ gr_clock_recovery_mm_ff::general_work (int noutput_items,
     }
   }
 
-//  consume_each (ii);
+  consume_each (ii);
 
-  return ii; //noutput_items;
+  return noutput_items;
 }
index edb27b62c225827ed743227fa57c111ca8fee0ea..664e369fa5f512d2120ffa5db6657fabd2bb13b7 100644 (file)
@@ -27,7 +27,7 @@
 #include <pmt_pool.h>
 
 static const int CACHE_LINE_SIZE = 64; // good guess
-static const int MAX_MESSAGES =  0;    // KLUDGE max number of messages in sys
+static const int MAX_MESSAGES =  1024; // KLUDGE max number of messages in sys
                                        //   0 -> no limit
 #if MB_MESSAGE_LOCAL_ALLOCATOR
 
index b08ef01e3f9c63e4610dd103aa4964967ed9b698..ca9009f54ad369e91308a80aeba7ccf82b94f048 100644 (file)
@@ -73,7 +73,12 @@ include_HEADERS =                    \
        usrp_server.h                   \
        usrp_tx.h                       \
        usrp_tx_stub.h                  \
-       usrp_usb_interface.h \
+       usrp_usb_interface.h
+
+noinst_HEADERS =                       \
+       qa_inband.h                     \
+       qa_inband_packet_prims.h        \
+       qa_inband_usrp_server.h         \
        symbols_usrp_channel.h          \
        symbols_usrp_interface_cs.h     \
        symbols_usrp_low_level_cs.h     \
@@ -83,11 +88,6 @@ include_HEADERS =                    \
        symbols_usrp_tx.h               \
        symbols_usrp_tx_cs.h
 
-noinst_HEADERS =                       \
-       qa_inband.h                     \
-       qa_inband_packet_prims.h        \
-       qa_inband_usrp_server.h         
-
 # ------------------------------------------------------------------------
 # Build the qa code in its own library
 
index 0d324789fa680c91f5ae39d91fd9aba322d32140..cd77974c7458a9a7b7cc665412b71a6846d04410 100644 (file)
@@ -112,7 +112,7 @@ usrp_usb_interface::usrp_usb_interface(mb_runtime *rt, const std::string &instan
                                 pmt_intern("rf-freq"), 
                                 PMT_NIL)) {
       if(!pmt_eqv(rf_freq, PMT_NIL)) 
-        d_rf_freq = pmt_to_double(rf_freq);
+        d_rf_freq = pmt_to_long(rf_freq);
     }
   }