howto: adds --disable-python option to gr-howto-write-a-block example.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 6 Aug 2009 23:21:40 +0000 (23:21 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 6 Aug 2009 23:21:40 +0000 (23:21 +0000)
Signed-off-by: Johnathan Corgan <jcorgan@corganenterprises.com>
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11542 221aa14e-8319-0410-a670-987f0aec2ac5

gr-howto-write-a-block/config/gr_standalone.m4
gr-howto-write-a-block/src/Makefile.am
gr-howto-write-a-block/src/lib/Makefile.am

index 44d9235f45fd5925a5d7e0ba98de356e232206c4..2f8851676d1def6f0c138eb7c6aa808b5df17379 100644 (file)
@@ -116,4 +116,18 @@ m4_define([GR_STANDALONE],
 
   PKG_CHECK_MODULES(GNURADIO_CORE, gnuradio-core >= 3)
   LIBS="$LIBS $GNURADIO_CORE_LIBS"
+
+  dnl Allow user to choose whether to generate SWIG/Python 
+  dnl Default is enabled
+  AC_ARG_ENABLE([python],
+    [AS_HELP_STRING([--enable-python],
+      [generate SWIG/Python components (default is yes)])],
+    [case "${enableval}" in
+       yes) enable_python=yes ;;
+       no) enable_python=no ;;
+       *) AC_MSG_ERROR([bad value ${enableval} for --enable-python]) ;;
+     esac],
+    [enable_python=yes]  
+  )
+  AM_CONDITIONAL([PYTHON], [test x$enable_python = xyes])
 ])
index e3f0399eb093e516a323ed1c5d4a6f7eb12c6cc9..4c8650d7d8258a80fe23dd5ff95faa372006b669 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004 Free Software Foundation, Inc.
+# Copyright 2004,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -19,4 +19,8 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-SUBDIRS = lib python
+SUBDIRS = lib
+
+if PYTHON
+SUBDIRS += python
+endif
index 5b6d5136a58d66df00a26a7e7a1fded121e50a58..fa6b439eaf78740a556653c83f11a527565ef9ec 100644 (file)
 
 include $(top_srcdir)/Makefile.common
 
+###################################
+# howto C++ library
+
 # C/C++ headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =            \
        howto_square_ff.h       \
        howto_square2_ff.h
 
+lib_LTLIBRARIES = libgnuradio-howto.la
+
+libgnuradio_howto_la_SOURCES =         \
+       howto_square_ff.cc      \
+       howto_square2_ff.cc
+
+libgnuradio_howto_la_LIBADD =  \
+       $(GNURADIO_CORE_LA)
+
+libgnuradio_howto_la_LDFLAGS = \
+       $(NO_UNDEFINED)
+
+if PYTHON
 ###################################
 # SWIG Python interface and library
 
@@ -39,34 +55,8 @@ TOP_SWIG_IFILES =            \
 howto_pythondir_category =     \
        gnuradio
 
-# additional arguments to the SWIG command
-#howto_la_swig_args =          \
-#      -g
-
-# additional sources for the SWIG-generated library
-howto_la_swig_sources =        \
-       howto_square_ff.cc      \
-       howto_square2_ff.cc
-
-# additional arguments to the SWIG command
-#howto_la_swig_args =          \
-#      $(SWIG_PYTHON_ARGS)
-
-# additional libraries for linking with the SWIG-generated library
-#howto_la_swig_libadd =                \
-#      libm.dylib
-
-# additional LD flags for linking the SWIG-generated library
-#howto_la_swig_ldflags =       \
-#      -L/opt/local/bin
-
-# additional Python files to be installed along with the SWIG-generated one
-#howto_python =                        \
-#      __init__.py
-
-# additional SWIG files to be installed
-#howto_swiginclude_headers =   \
-#      nothing.i
+howto_la_swig_libadd =         \
+       libgnuradio-howto.la
 
 include $(top_srcdir)/Makefile.swig
 
@@ -75,3 +65,4 @@ BUILT_SOURCES = $(swig_built_sources)
 
 # Do not distribute the output of SWIG
 no_dist_files = $(swig_built_sources)
+endif