Added README and updated configuration requirements
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 23 Sep 2009 18:56:19 +0000 (11:56 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 23 Sep 2009 19:23:41 +0000 (12:23 -0700)
config/grc_gr_noaa.m4
gr-noaa/README [new file with mode: 0644]

index fbc31fc2bf8d40054b6aef8721549234d63aa80b..b00579ff589b5fc10c311312b81cef4464e7b3d9 100644 (file)
@@ -22,6 +22,8 @@ AC_DEFUN([GRC_GR_NOAA],[
 
     dnl Don't do gr-noaa if gnuradio-core skipped
     GRC_CHECK_DEPENDENCY(gr-noaa, gnuradio-core)
+    GRC_CHECK_DEPENDENCY(gr-noaa, gr-wxgui)
+    GRC_CHECK_DEPENDENCY(gr-noaa, grc)
 
     AC_CONFIG_FILES([\
         gr-noaa/Makefile \
diff --git a/gr-noaa/README b/gr-noaa/README
new file mode 100644 (file)
index 0000000..d99c0d9
--- /dev/null
@@ -0,0 +1,53 @@
+This component implements an NOAA POES HRPT receiver.  After installation,
+the scripts described below will be install in the users PATH.
+
+As the scripts are generated using GRC, GRC must be installed at runtime
+in order for them to operate.
+
+
+HRPT Operation
+--------------
+
+usrp_rx_hrpt.py
+
+This GUI script will receive HRPT RF, demodulate, synchronize, and deframe
+HRPT minor frames into a file.  The file stores a series of 11090 word,
+16-bits per word corresponding to the HRPT minor frame format (only the
+lower 10-bits per word are significant.)
+
+The script file by default uses USRP side A, 1698 MHz, at decimation 16. A
+configuration file 'usrp_rx_hrpt.cfg' in the current working directory will
+allow changing this, as well as implementing persistent storage of GUI
+entered parameters from invocation to invocation.
+
+The present HRPT demodulator is only tested at decimation 16.  The only other
+valid decimation rates are 24 and 32, which may word but with more bit
+errors.  No other decimation rates will work.
+
+
+demod_hrpt_file.py
+
+This command-line only script will operate on a file generated with
+usrp_rx_cfile.py and output frames in the same format as above.  It does
+*not* use the configuration file above.
+
+Usage: demod_hrpt_file.py: [options]
+
+Options:
+  -h, --help            show this help message and exit
+  -d DECIM, --decim=DECIM
+                        Set Decimation [default=16]
+  -p PLL_ALPHA, --pll-alpha=PLL_ALPHA
+                        Set pll_alpha [default=50m]
+  -s SYNC_ALPHA, --sync-alpha=SYNC_ALPHA
+                        Set sync_alpha [default=50m]
+  -F FILENAME, --filename=FILENAME
+                        Set Filename [default=usrp.dat]
+  -o OUTPUT, --output=OUTPUT
+                        Set Output [default=frames.dat]
+
+
+LRIT Operation
+--------------
+
+The work-in-progress LRIT GRC script is not currently in a usable state.