2007-05-14 Greg Troxel <Greg Troxel <gdt@ir.bbn.com>>
authorgdt <gdt@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 14 May 2007 14:16:44 +0000 (14:16 +0000)
committergdt <gdt@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 14 May 2007 14:16:44 +0000 (14:16 +0000)
        * host/lib/legacy/usrp_bytesex.h: Fix typo in portability code.
        Add #warning that it is non-portable.

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@5465 221aa14e-8319-0410-a670-987f0aec2ac5

usrp/ChangeLog
usrp/host/lib/legacy/usrp_bytesex.h

index 69da6041874463a51b2425a13e0e977f73e645ae..4bdb7c619c30ece34b4b35ae15f4132f81d6db9d 100644 (file)
@@ -1,3 +1,8 @@
+2007-05-14  Greg Troxel  <Greg Troxel <gdt@ir.bbn.com>>
+
+       * host/lib/legacy/usrp_bytesex.h: Fix typo in portability code.
+       Add #warning that it is non-portable.
+
 2006-10-10  Greg Troxel  <gdt@ir.bbn.com>
 
        * firmware/include/Makefile.am: avoid nonportable use of $< (first
index 6c4e129c9d2be267c809c9d119a3535b0c6c28f2..955faf242ccea2acba6370419f77b239d11be093 100644 (file)
@@ -33,6 +33,9 @@
 #ifdef HAVE_BYTESWAP_H
 #include <byteswap.h>
 #else
+
+#warning Using non-portable code (likely wrong other than ILP32).
+
 static inline unsigned short int
 bswap_16 (unsigned short int x)
 {
@@ -40,7 +43,7 @@ bswap_16 (unsigned short int x)
 }
 
 static inline unsigned int
-bswap32 (unsigned int x)
+bswap_32 (unsigned int x)
 {
   return ((((x) & 0xff000000) >> 24) | (((x) & 0x00ff0000) >>  8) \
         | (((x) & 0x0000ff00) <<  8) | (((x) & 0x000000ff) << 24));