Now passes distcheck with or without microblaze tools on path.
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 8 Sep 2008 23:08:46 +0000 (23:08 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 8 Sep 2008 23:08:46 +0000 (23:08 +0000)
Merged eb/distcheck 9534:9537 into trunk.

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9538 221aa14e-8319-0410-a670-987f0aec2ac5

Makefile.am
config/grc_usrp2.m4
usrp2/Makefile.am

index 91b0e5d22a7c11bef7a9bdfb90e54dc204cbcb5c..b5d4f94550f7beee25107a275fbc4c60a95697f7 100644 (file)
@@ -33,4 +33,4 @@ EXTRA_DIST = \
        README.building-boost
 
 SUBDIRS = @build_dirs@ $(subdirs)
-DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@ $(subdirs)
index f842a79a6cf84dd9eae3202cabc22664721eca55..ec88ab3453a639ef614e7f104f6af73b92562b2e 100644 (file)
@@ -25,14 +25,14 @@ AC_DEFUN([GRC_USRP2],[
     GRC_CHECK_DEPENDENCY(usrp2, omnithread)
 
     dnl USRP2 host code only works on Linux at the moment
-    AC_MSG_CHECKING([whether host_cpu is linux*])
+    AC_MSG_CHECKING([whether host_os is linux*])
     case "$host_os" in
       linux*)
-       AC_MSG_RESULT("yes")
+       AC_MSG_RESULT([yes])
         ;;
       *)
-       AC_MSG_RESULT("no")
-       echo "USRP2 requires Linux host OS, not found"
+       AC_MSG_RESULT([no])
+       AC_MSG_NOTICE([USRP2 currently requires Linux host OS, not found])
         passed="no"
         ;;
     esac
@@ -47,7 +47,10 @@ AC_DEFUN([GRC_USRP2],[
        if test $MB_GCC = yes; then
            dnl Adds usrp2/firmware to $(subdirs), hierarchical build
            AC_CONFIG_SUBDIRS([usrp2/firmware])
+       else
+           AC_MSG_WARN([usrp2/firmware is not being built])
        fi
+       AM_CONDITIONAL([BUILDING_USRP2_FIRMWARE],[test $MB_GCC = yes])
 
        dnl Needed for usrp2_socket_opener
        AC_CHECK_HEADERS(arpa/inet.h byteswap.h linux/if_packet.h sys/socket.h sys/un.h)
index 1ea058902cd426d79de4ab31a436582ab60f5b98..c478df9bc1f74526544ff34f7f9f8a7d467fbf4d 100644 (file)
 include $(top_srcdir)/Makefile.common
 
 SUBDIRS = host
+
+# KLUDGE ALERT!
+#
+# This kludge gets the files the host code needs into the tarball even if
+# we're not building the firmware.
+#
+if !BUILDING_USRP2_FIRMWARE
+EXTRA_DIST = \
+    firmware/include/usrp2_cdefs.h \
+    firmware/include/usrp2_cdefs.h \
+    firmware/include/usrp2_eth_packet.h \
+    firmware/include/usrp2_fpga_regs.h \
+    firmware/include/usrp2_i2c_addr.h \
+    firmware/include/usrp2_mac_addr.h \
+    firmware/include/usrp2_mimo_config.h \
+    firmware/include/usrp2_types.h
+endif