Rename binary to be more descriptive.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 25 Jul 2009 14:55:06 +0000 (14:55 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 25 Jul 2009 14:55:06 +0000 (14:55 +0000)
gnuradio --> gnuradio-config-info

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11475 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-core/src/lib/Makefile.am
gnuradio-core/src/lib/gnuradio-config-info.cc [new file with mode: 0644]
gnuradio-core/src/lib/gnuradio.cc [deleted file]

index 8b2dc82ccc35dc8e1ab907147d81796c01b4394a..b3b42b03f66e7efb337bdbf2dbf9dae1e7fbc24d 100644 (file)
@@ -67,6 +67,6 @@ libgnuradio_core_qa_la_LIBADD  =      \
        libgnuradio-core.la             \
        $(CPPUNIT_LIBS)                 
 
-bin_PROGRAMS = gnuradio
-gnuradio_SOURCES = gnuradio.cc
-gnuradio_LDADD = libgnuradio-core.la $(BOOST_PROGRAM_OPTIONS_LIB)
+bin_PROGRAMS = gnuradio-config-info
+gnuradio_config_info_SOURCES = gnuradio-config-info.cc
+gnuradio_config_info_LDADD = libgnuradio-core.la $(BOOST_PROGRAM_OPTIONS_LIB)
\ No newline at end of file
diff --git a/gnuradio-core/src/lib/gnuradio-config-info.cc b/gnuradio-core/src/lib/gnuradio-config-info.cc
new file mode 100644 (file)
index 0000000..df78ea2
--- /dev/null
@@ -0,0 +1,80 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2009 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
+
+#include <gr_constants.h>
+#include <boost/program_options.hpp>
+#include <iostream>
+
+namespace po = boost::program_options;
+
+int
+main(int argc, char **argv)
+{
+  po::options_description desc("Program options: gnuradio [options]");
+  po::variables_map vm;
+
+  desc.add_options()
+    ("help,h", "print help message")
+    ("prefix", "print gnuradio installation prefix")
+    ("sysconfdir", "print gnuradio system configuration directory")
+    ("prefsdir", "print gnuradio preferences directory")
+    ("builddate", "print gnuradio build date (RFC2822 format)")
+    ("version,v", "print gnuradio version")
+    ("svnversion", "print SVN repository version (SVN format)")
+    ("svndate", "print SVN repository date")
+    ;
+
+  po::store(po::parse_command_line(argc, argv, desc), vm);
+  po::notify(vm);
+
+  if (vm.size() == 0 || vm.count("help")) {
+    std::cout << desc << std::endl;
+    return 1;
+  }
+      
+  if (vm.count("prefix"))
+    std::cout << gr_prefix() << std::endl;
+
+  if (vm.count("sysconfdir"))
+    std::cout << gr_sysconfdir() << std::endl;
+
+  if (vm.count("prefsdir"))
+    std::cout << gr_prefsdir() << std::endl;
+
+  if (vm.count("builddate"))
+    std::cout << gr_build_date() << std::endl;
+
+  if (vm.count("version"))
+    std::cout << gr_version() << std::endl;
+
+  if (vm.count("svnversion"))
+    std::cout << gr_svn_version() << std::endl;
+
+  if (vm.count("svndate"))
+    std::cout << gr_svn_date() << std::endl;
+
+  return 0;
+}
diff --git a/gnuradio-core/src/lib/gnuradio.cc b/gnuradio-core/src/lib/gnuradio.cc
deleted file mode 100644 (file)
index df78ea2..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2009 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 3, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#if HAVE_CONFIG_H
-#include <config.h>
-#endif
-
-#include <gr_constants.h>
-#include <boost/program_options.hpp>
-#include <iostream>
-
-namespace po = boost::program_options;
-
-int
-main(int argc, char **argv)
-{
-  po::options_description desc("Program options: gnuradio [options]");
-  po::variables_map vm;
-
-  desc.add_options()
-    ("help,h", "print help message")
-    ("prefix", "print gnuradio installation prefix")
-    ("sysconfdir", "print gnuradio system configuration directory")
-    ("prefsdir", "print gnuradio preferences directory")
-    ("builddate", "print gnuradio build date (RFC2822 format)")
-    ("version,v", "print gnuradio version")
-    ("svnversion", "print SVN repository version (SVN format)")
-    ("svndate", "print SVN repository date")
-    ;
-
-  po::store(po::parse_command_line(argc, argv, desc), vm);
-  po::notify(vm);
-
-  if (vm.size() == 0 || vm.count("help")) {
-    std::cout << desc << std::endl;
-    return 1;
-  }
-      
-  if (vm.count("prefix"))
-    std::cout << gr_prefix() << std::endl;
-
-  if (vm.count("sysconfdir"))
-    std::cout << gr_sysconfdir() << std::endl;
-
-  if (vm.count("prefsdir"))
-    std::cout << gr_prefsdir() << std::endl;
-
-  if (vm.count("builddate"))
-    std::cout << gr_build_date() << std::endl;
-
-  if (vm.count("version"))
-    std::cout << gr_version() << std::endl;
-
-  if (vm.count("svnversion"))
-    std::cout << gr_svn_version() << std::endl;
-
-  if (vm.count("svndate"))
-    std::cout << gr_svn_date() << std::endl;
-
-  return 0;
-}