Don't distribute generated files in gr-qtgui
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 22 Oct 2009 18:12:42 +0000 (11:12 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 22 Oct 2009 18:12:42 +0000 (11:12 -0700)
The output of the moc compiler will contain generated paths which are
only valid on the system at compilation time.  Instead, let these
get regenerated on the user's system.  The moc compiler is part of
libqt4-dev, which is already a build dependency.

gr-qtgui/src/lib/Makefile.am

index 6c90c31f0f946687b15ceb65ae79d721de794ec6..814bee1369ef033798263482e6eac1c3aff1e5e2 100644 (file)
@@ -112,7 +112,8 @@ include $(top_srcdir)/Makefile.swig
 # add some of the variables generated inside the Makefile.swig.gen
 BUILT_SOURCES +=               \
        $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
 endif
+
+# Do not distribute built sources, they may contain generated paths
+# which are invalid on other systems
+no_dist_files = $(BUILT_SOURCES)