Imported Upstream version 3.3.0
[debian/amanda] / packaging / deb / rules
index 279863b8d89b830f1aa95bdcbf7955402b089e8f..1d75bbed5ea1022b5c5f9aed109538a1b8f628f5 100755 (executable)
@@ -1,14 +1,13 @@
 #!/usr/bin/make -f
 # debian/rules for amanda using debhelper. GNU copyright 2008 by Dan Locks, 
 # based on work by Bdale Garbee.
-# requires automake 1.2d (from experimental tree)
 
 #      Warning - do *not* use -j on an SMP machine, or the build gets
 #              confused... some sort of race condition in the makefiles?
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
-AMVER=2.6.2alpha
+AMVER=3.2alpha
 
 # These are variables that the user can override.  They get used in various
 # places during configure, build, and install.
@@ -53,6 +52,7 @@ build-stamp: /sbin/dump /usr/bin/smbclient
                MAKEFLAGS="-j1 " \
                CFLAGS="-pipe " \
                MAILER=/usr/bin/mail \
+               --enable-as-needed \
                --quiet \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
@@ -76,9 +76,6 @@ build-stamp: /sbin/dump /usr/bin/smbclient
                --with-amandahosts \
                --with-smbclient=$(BINDIR)/smbclient \
                --with-debugging=$(LOGDIR) \
-               --with-tcpportrange=11000,11040 \
-                --with-low-tcpportrange=700,710 \
-               --with-udpportrange=700,740 \
                --with-ssh-security \
                --with-assertions \
                --enable-s3-device \
@@ -161,7 +158,8 @@ binary-arch: build
                $(server)/$(AMLIBEXECDIR)/calcsize \
                $(server)/$(AMLIBEXECDIR)/dumper \
                $(server)/$(AMLIBEXECDIR)/planner \
-               $(server)/usr/sbin/amcheck
+               $(server)/usr/sbin/amcheck \
+               $(server)/usr/sbin/amservice
        chmod u=srwx,g=rx,o=r \
                $(client)/$(AMLIBEXECDIR)/application/amgtar \
                $(client)/$(AMLIBEXECDIR)/application/amstar \
@@ -177,7 +175,8 @@ binary-arch: build
                $(server)$(AMLIBEXECDIR)/calcsize \
                $(server)$(AMLIBEXECDIR)/dumper \
                $(server)$(AMLIBEXECDIR)/planner \
-               $(server)/usr/sbin/amcheck
+               $(server)/usr/sbin/amcheck \
+               $(server)/usr/sbin/amservice
        echo "Amanda version $(AMVER)" >  $(server)/$(AMANDAHOMEDIR)/amanda-release 
        echo "Amanda version $(AMVER)" >  $(client)/$(AMANDAHOMEDIR)/amanda-release 
        install -o root -g root -m 0644 debian/amanda-backup-client.lintian \