Whoops. Time intervals are specified in seconds, not ms...
[debian/gnuradio] / omnithread / Makefile.am
index 2eac4c920c267ac08cd43e38f0b50fe895533c8f..291cc8beb0eaa16201221f353cc9332f4b9ce3e6 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2003 Free Software Foundation, Inc.
+# Copyright 2003,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 
 include $(top_srcdir)/Makefile.common
 
+SUBDIRS = gnuradio
+
 # This is the omnithread package,
 #   extracted from the omniORB-4.0.1 distribution
 
 # we should do some configure hacking to determine these on the fly
 OMNITHREAD_DEFINES = -DPthreadDraftVersion=10
 
-INCLUDES = $(DEFINES) $(OMNITHREAD_DEFINES) $(OMNITHREAD_INCLUDES)
+AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_DEFINES) $(OMNITHREAD_INCLUDES) \
+        $(WITH_INCLUDES)
 
 # we call it libgromnithread to avoid a collision with libomnithread on Debian
 lib_LTLIBRARIES = libgromnithread.la
@@ -36,33 +39,33 @@ lib_LTLIBRARIES = libgromnithread.la
 
 if OMNITHREAD_POSIX
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        posix.cc
 endif
 
 if OMNITHREAD_NT
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        nt.cc
 endif
 
+libgromnithread_la_LDFLAGS = $(NO_UNDEFINED) 
+
 libgromnithread_la_LIBADD =            \
        $(PTHREAD_LIBS)
 
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gnuradio-omnithread.pc
+
 # ... but this code also came with the package
 
 EXTRA_DIST =                           \
+       gnuradio-omnithread.pc.in       \
        mach.cc                         \
        nt.cc                           \
        posix.cc                        \
        solaris.cc                      \
        threaddata.cc                   \
        vxWorks.cc                      \
-       dir.mk
-
-grinclude_HEADERS =                    \
-       omnithread.h                    \
-       ot_mach.h                       \
-       ot_nt.h                         \
-       ot_posix.h                      \
-       ot_pthread_nt.h                 \
-       ot_solaris.h                    \
-       ot_VxThread.h                   
+       dir.mk                          \
+       README