Finally, the simple fix for the qtgui issues; also, changed the naming scheme output...
[debian/gnuradio] / gr-qtgui / src / lib / Makefile.am
index bd9c945bc948c8dd74aea5f7497c31fc2836ef2c..7a03e1978b1fea37cf1538a3705804719d5af0b3 100644 (file)
@@ -27,12 +27,12 @@ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
 # Only include these files in the build if qtgui passes configure checks
 # This is mostly to help make distcheck pass
 QMAKE_SOURCES =                                \
-       spectrumdisplayform_moc.cc              \
-       FrequencyDisplayPlot_moc.cc             \
-       TimeDomainDisplayPlot_moc.cc            \
-       WaterfallDisplayPlot_moc.cc             \
-       ConstellationDisplayPlot_moc.cc         \
-       spectrumdisplayform_ui.h
+       spectrumdisplayform.moc.cc              \
+       FrequencyDisplayPlot.moc.cc             \
+       TimeDomainDisplayPlot.moc.cc            \
+       WaterfallDisplayPlot.moc.cc             \
+       ConstellationDisplayPlot.moc.cc         \
+       spectrumdisplayform.ui.h
 
 EXTRA_DIST = spectrumdisplayform.ui
 
@@ -55,6 +55,8 @@ libgnuradio_qtgui_la_SOURCES =        \
        qtgui_sink_c.cc                         \
        qtgui_sink_f.cc
 
+nodist_libgnuradio_qtgui_la_SOURCES=$(BUILT_SOURCES)
+
 # These headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =                    \
        FrequencyDisplayPlot.h          \
@@ -71,10 +73,12 @@ grinclude_HEADERS =                 \
        qtgui_sink_c.h                  \
        qtgui_sink_f.h
 
-%_moc.cc : %.h
-       $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@
 
-%_ui.h : %.ui
+QT_MOC_FLAGS=-DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB
+%.moc.cc : %.h
+       $(QT_MOC_EXEC) $(QT_MOC_FLAGS) -p $(srcdir) $< -o $@
+
+%.ui.h : %.ui
        $(QT_UIC_EXEC) $< -o $@
 
 # magic flags