howto: make versioned libraries
[debian/gnuradio] / gr-howto-write-a-block / lib / Makefile.am
index e553c193de391b8848462509b14bbdbf75e99145..f0a18358f0b4ede68704e182254527e955eda12f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 
 include $(top_srcdir)/Makefile.common
 
-###################################
-# howto C++ library
+# list of programs run by "make check" and "make distcheck"
+TESTS = test_all
 
-# C/C++ headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS =            \
-       howto_square_ff.h       \
+# ----------------------------------------------------------------
+# howto C++ library: libgnuradio-howto.so
+# ----------------------------------------------------------------
+
+# C/C++ headers get installed in ${prefix}/include/$(modname)
+modinclude_HEADERS = \
+       howto_square_ff.h \
        howto_square2_ff.h
 
 lib_LTLIBRARIES = libgnuradio-howto.la
 
-libgnuradio_howto_la_SOURCES =         \
-       howto_square_ff.cc      \
+libgnuradio_howto_la_SOURCES = \
+       howto_square_ff.cc \
        howto_square2_ff.cc
 
-libgnuradio_howto_la_LIBADD =  \
+libgnuradio_howto_la_LIBADD = \
        $(GNURADIO_CORE_LA)
 
-libgnuradio_howto_la_LDFLAGS = \
-       $(NO_UNDEFINED)
+libgnuradio_howto_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
+
+# ----------------------------------------------------------------
+# howto C++ QA library: libgnuradio-howto-qa.so (not installed)
+# ----------------------------------------------------------------
+
+noinst_LTLIBRARIES = libgnuradio-howto-qa.la
+
+libgnuradio_howto_qa_la_SOURCES = \
+       qa_howto.cc \
+       qa_howto_square_ff.cc \
+       qa_howto_square2_ff.cc
+
+libgnuradio_howto_qa_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
+
+libgnuradio_howto_qa_la_LIBADD = \
+       libgnuradio-howto.la \
+       $(CPPUNIT_LIBS)
+
+# ----------------------------------------------------------------
+# headers that don't get installed
+# ----------------------------------------------------------------
+noinst_HEADERS = \
+       qa_howto.h \
+       qa_howto_square_ff.h \
+       qa_howto_square2_ff.h
+
+# ----------------------------------------------------------------
+# test program
+# ----------------------------------------------------------------
+noinst_PROGRAMS = \
+       test_all
+
+test_all_SOURCES = test_all.cc
+test_all_LDADD   = libgnuradio-howto-qa.la