howto: moved osbsolete docs directory into limbo
[debian/gnuradio] / gr-howto-write-a-block / configure.ac
index da456e03cd283fb2ef821c5098ae37b72971771b..8241f7ec1aaea4ae1589065c3199a3e4c43e1957 100644 (file)
@@ -1,5 +1,5 @@
 dnl 
-dnl  Copyright 2004,2005,2007,2008 Free Software Foundation, Inc.
+dnl  Copyright 2004,2005,2007,2008,2009 Free Software Foundation, Inc.
 dnl  
 dnl  This file is part of GNU Radio
 dnl  
@@ -19,10 +19,20 @@ dnl  the Free Software Foundation, Inc., 51 Franklin Street,
 dnl  Boston, MA 02110-1301, USA.
 dnl 
 
-AC_INIT(gr-howto-write-a-block,3.2svn)
+
+AC_INIT
 AC_PREREQ(2.57)
 AC_CONFIG_AUX_DIR([.]) 
 
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
+
+GR_VERSION
+dnl ustar required to have pathnames > 99 chars
+_AM_SET_OPTION([tar-ustar])
+AM_INIT_AUTOMAKE(gr-howto-write-a-block,$RELEASE)
+
 dnl This is kind of non-standard, but it sure shortens up this file :-)
 m4_include([config/gr_standalone.m4])
 GR_STANDALONE
@@ -62,14 +72,15 @@ dnl AX_BOOST_WSERIALIZATION
 AC_CONFIG_FILES([\
          Makefile \
          config/Makefile \
-         doc/Makefile \
-         src/Makefile \
-         src/lib/Makefile \
-         src/python/Makefile \
-         src/python/run_tests \
+         lib/Makefile \
+         python/Makefile \
+         python/run_tests \
+         swig/Makefile \
        ])
 
 dnl run_tests is created from run_tests.in.  Make it executable.
-AC_CONFIG_COMMANDS([run_tests], [chmod +x src/python/run_tests])
+AC_CONFIG_COMMANDS([run_tests], [chmod +x python/run_tests])
 
 AC_OUTPUT
+
+echo Configured gr-howto-write-a-block release $RELEASE for build.