Merged r4632:4645 on jcorgan/linking into trunk. Cleans up linking issues with libto...
[debian/gnuradio] / gr-ezdop / src / lib / Makefile.am
index c0cdacca6ef2cd2331f898f2f50f8c5b35e07bba..51d7e56c267aae05cb7ea070feec9128a7fdca8d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -32,7 +32,7 @@ EZDOP_INCLUDES = \
     -I$(top_srcdir)/ezdop/src/firmware \
     -I$(top_srcdir)/ezdop/src/host/ezdop
 
-EZDOP_LIBS = -L$(top_builddir)/ezdop/src/host/ezdop/ -lezdop
+EZDOP_LA = $(top_builddir)/ezdop/src/host/ezdop/libezdop.la
 
 INCLUDES = \
     $(STD_DEFINES_AND_INCLUDES) \
@@ -78,8 +78,8 @@ _ezdop_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 # c++ standard library
 _ezdop_la_LIBADD =                     \
        $(PYTHON_LDFLAGS)               \
-       $(GNURADIO_CORE_LIBS)           \
-       $(EZDOP_LIBS)                   \
+       $(GNURADIO_CORE_LA)             \
+       $(EZDOP_LA)                     \
        -lstdc++                        
 
 ezdop.cc ezdop.py: $(ALL_IFILES)
@@ -89,7 +89,6 @@ ezdop.cc ezdop.py: $(ALL_IFILES)
 grinclude_HEADERS =                    \
        ezdop_source_c.h
 
-
 # These swig headers get installed in ${prefix}/include/gnuradio/swig
 swiginclude_HEADERS =                  \
        $(LOCAL_IFILES)