Merge branch 'dfsg-orig'
[debian/gnuradio] / gr-cvsd-vocoder / src / lib / Makefile.am
index 402a10eedebd87409b3def359495bca5c2458766..c5957f4acc7cbabd21e7d8e0f33562de877d44f4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004,2005,2008 Free Software Foundation, Inc.
+# Copyright 2004,2005,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 
 include $(top_srcdir)/Makefile.common
 
-# Install this stuff so that it ends up as the gnuradio.vocoder module
-# This usually ends up at:
-#   ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
-
-ourpythondir = $(grpythondir)/vocoder
-ourlibdir    = $(grpyexecdir)/vocoder
-
 AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
 
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES) \
-       $(WITH_SWIG_INCLUDES) $(WITH_INCLUDES)
-
-ALL_IFILES =                           \
-       $(LOCAL_IFILES)                 \
-       $(NON_LOCAL_IFILES)             
-
-NON_LOCAL_IFILES =                     \
-       $(GNURADIO_I)
-
-LOCAL_IFILES =                                 \
-       $(top_srcdir)/gr-cvsd-vocoder/src/lib/cvsd_vocoder.i
-
-# These files are built by SWIG.  The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
-
-BUILT_SOURCES =                        \
-       cvsd_vocoder.cc         \
-       cvsd_vocoder.py                         
-
-# This gets cvsd_vocoder.py installed in the right place
-ourpython_PYTHON =                     \
-       cvsd_vocoder.py
+# These headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS =                    \
+       cvsd_decode_bs.h                \
+       cvsd_encode_sb.h
 
-ourlib_LTLIBRARIES = _cvsd_vocoder.la
+lib_LTLIBRARIES = libgnuradio-cvsd-vocoder.la
 
-# These are the source files that go into the shared library
-_cvsd_vocoder_la_SOURCES =             \
+libgnuradio_cvsd_vocoder_la_SOURCES =  \
        cvsd_decode_bs.cc               \
-       cvsd_encode_sb.cc               \
-       cvsd_vocoder.cc         
-
+       cvsd_encode_sb.cc
 
-# magic flags
-_cvsd_vocoder_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
+libgnuradio_cvsd_vocoder_la_LIBADD =   \
+       $(GNURADIO_CORE_LA)
 
-# link the library against the c++ standard library
-_cvsd_vocoder_la_LIBADD =      \
-       $(PYTHON_LDFLAGS)       \
-       $(GNURADIO_CORE_LA)     \
-       -lstdc++                        
+libgnuradio_cvsd_vocoder_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
-cvsd_vocoder.cc cvsd_vocoder.py: cvsd_vocoder.i $(ALL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module cvsd_vocoder -o cvsd_vocoder.cc $(LOCAL_IFILES)
+if PYTHON
+###################################
+# SWIG Python interface and library
 
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS =                    \
-       cvsd_decode_bs.h                \
-       cvsd_encode_sb.h                
+TOP_SWIG_IFILES =                      \
+       cvsd_vocoder.i
 
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS =                  \
-       $(LOCAL_IFILES)
+# Install so that they end up available as:
+#   import gnuradio.vocoder.cvsd_vocoder
+# This ends up at:
+#   ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
+cvsd_vocoder_pythondir_category =      \
+       gnuradio/vocoder
 
+# additional libraries for linking with the SWIG-generated library
+cvsd_vocoder_la_swig_libadd =          \
+       libgnuradio-cvsd-vocoder.la
 
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+include $(top_srcdir)/Makefile.swig
 
-# Don't distribute output of swig
-dist-hook:
-       @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
-       @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
 
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+endif