Imported Upstream version 3.0.4
[debian/gnuradio] / gr-audio-osx / src / Makefile.in
index 4d228433465f120d65d6c89546414479ce54d92c..71286e231c0e6ccf975402fde9b4b6825ff55dbe 100644 (file)
@@ -21,7 +21,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -88,7 +88,7 @@ DIST_COMMON = $(grinclude_HEADERS) $(noinst_HEADERS) $(noinst_PYTHON) \
 subdir = gr-audio-osx/src
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
 am__aclocal_m4_deps = $(top_srcdir)/config/acx_pthread.m4 \
-       $(top_srcdir)/config/cppunit.m4 $(top_srcdir)/config/gr_as.m4 \
+       $(top_srcdir)/config/cppunit.m4 \
        $(top_srcdir)/config/gr_boost.m4 \
        $(top_srcdir)/config/gr_check_createfilemapping.m4 \
        $(top_srcdir)/config/gr_check_shm_open.m4 \
@@ -145,8 +145,10 @@ am__installdirs = "$(DESTDIR)$(ourlibdir)" "$(DESTDIR)$(ourpythondir)" \
 ourlibLTLIBRARIES_INSTALL = $(INSTALL)
 LTLIBRARIES = $(ourlib_LTLIBRARIES)
 am__DEPENDENCIES_1 =
+am__DEPENDENCIES_2 =  \
+       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 _audio_osx_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-       $(am__DEPENDENCIES_1)
+       $(am__DEPENDENCIES_2)
 am__audio_osx_la_OBJECTS = audio_osx.lo audio_osx_sink.lo \
        audio_osx_source.lo
 _audio_osx_la_OBJECTS = $(am__audio_osx_la_OBJECTS)
@@ -408,25 +410,17 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    $(FFTW3F_CFLAGS)
 
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 
 # This is a dependency for many swig operations
 GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
+# How to link in the USRP library from inside the tree
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
-
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
@@ -482,7 +476,7 @@ swiginclude_HEADERS = \
 
 _audio_osx_la_LIBADD = \
        $(PYTHON_LDFLAGS)               \
-       $(GNURADIO_CORE_LIBS)           \
+       $(GNURADIO_CORE_LA)             \
        -lstdc++                                
 
 _audio_osx_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version -framework AudioUnit -framework CoreAudio -framework AudioToolbox