Imported Upstream version 3.0.4
[debian/gnuradio] / gnuradio-core / src / tests / Makefile.in
index 1c2fbeaa77451cff603b3fff3df7f7e325830633..00c51562b6346b5faf6649a17e6a874c3f3b8e84 100644 (file)
@@ -21,7 +21,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -92,7 +92,7 @@ noinst_PROGRAMS = benchmark_dotprod$(EXEEXT) \
 subdir = gnuradio-core/src/tests
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
 am__aclocal_m4_deps = $(top_srcdir)/config/acx_pthread.m4 \
-       $(top_srcdir)/config/cppunit.m4 $(top_srcdir)/config/gr_as.m4 \
+       $(top_srcdir)/config/cppunit.m4 \
        $(top_srcdir)/config/gr_boost.m4 \
        $(top_srcdir)/config/gr_check_createfilemapping.m4 \
        $(top_srcdir)/config/gr_check_shm_open.m4 \
@@ -144,46 +144,47 @@ am_benchmark_dotprod_OBJECTS = benchmark_dotprod.$(OBJEXT)
 benchmark_dotprod_OBJECTS = $(am_benchmark_dotprod_OBJECTS)
 am__DEPENDENCIES_1 =  \
        $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
-benchmark_dotprod_DEPENDENCIES = $(am__DEPENDENCIES_1)
+am__DEPENDENCIES_2 = $(am__DEPENDENCIES_1)
+benchmark_dotprod_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_dotprod_ccc_OBJECTS = benchmark_dotprod_ccc.$(OBJEXT)
 benchmark_dotprod_ccc_OBJECTS = $(am_benchmark_dotprod_ccc_OBJECTS)
-benchmark_dotprod_ccc_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_dotprod_ccc_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_dotprod_ccf_OBJECTS = benchmark_dotprod_ccf.$(OBJEXT)
 benchmark_dotprod_ccf_OBJECTS = $(am_benchmark_dotprod_ccf_OBJECTS)
-benchmark_dotprod_ccf_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_dotprod_ccf_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_dotprod_fcc_OBJECTS = benchmark_dotprod_fcc.$(OBJEXT)
 benchmark_dotprod_fcc_OBJECTS = $(am_benchmark_dotprod_fcc_OBJECTS)
-benchmark_dotprod_fcc_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_dotprod_fcc_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_dotprod_fsf_OBJECTS = benchmark_dotprod_fsf.$(OBJEXT)
 benchmark_dotprod_fsf_OBJECTS = $(am_benchmark_dotprod_fsf_OBJECTS)
-benchmark_dotprod_fsf_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_dotprod_fsf_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_dotprod_scc_OBJECTS = benchmark_dotprod_scc.$(OBJEXT)
 benchmark_dotprod_scc_OBJECTS = $(am_benchmark_dotprod_scc_OBJECTS)
-benchmark_dotprod_scc_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_dotprod_scc_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_nco_OBJECTS = benchmark_nco.$(OBJEXT)
 benchmark_nco_OBJECTS = $(am_benchmark_nco_OBJECTS)
-benchmark_nco_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_nco_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_benchmark_vco_OBJECTS = benchmark_vco.$(OBJEXT)
 benchmark_vco_OBJECTS = $(am_benchmark_vco_OBJECTS)
-benchmark_vco_DEPENDENCIES = $(am__DEPENDENCIES_1)
+benchmark_vco_DEPENDENCIES = $(am__DEPENDENCIES_2)
 am_test_all_OBJECTS = test_all.$(OBJEXT)
 test_all_OBJECTS = $(am_test_all_OBJECTS)
-am__DEPENDENCIES_2 =  \
+am__DEPENDENCIES_3 =  \
        $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core-qa.la \
-       $(am__DEPENDENCIES_1)
-test_all_DEPENDENCIES = $(am__DEPENDENCIES_2)
+       $(am__DEPENDENCIES_2)
+test_all_DEPENDENCIES = $(am__DEPENDENCIES_3)
 am_test_filter_OBJECTS = test_filter.$(OBJEXT)
 test_filter_OBJECTS = $(am_test_filter_OBJECTS)
-test_filter_DEPENDENCIES = $(am__DEPENDENCIES_2)
+test_filter_DEPENDENCIES = $(am__DEPENDENCIES_3)
 am_test_general_OBJECTS = test_general.$(OBJEXT)
 test_general_OBJECTS = $(am_test_general_OBJECTS)
-test_general_DEPENDENCIES = $(am__DEPENDENCIES_2)
+test_general_DEPENDENCIES = $(am__DEPENDENCIES_3)
 am_test_runtime_OBJECTS = test_runtime.$(OBJEXT)
 test_runtime_OBJECTS = $(am_test_runtime_OBJECTS)
-test_runtime_DEPENDENCIES = $(am__DEPENDENCIES_2)
+test_runtime_DEPENDENCIES = $(am__DEPENDENCIES_3)
 am_test_vmcircbuf_OBJECTS = test_vmcircbuf.$(OBJEXT)
 test_vmcircbuf_OBJECTS = $(am_test_vmcircbuf_OBJECTS)
-test_vmcircbuf_DEPENDENCIES = $(am__DEPENDENCIES_2)
+test_vmcircbuf_DEPENDENCIES = $(am__DEPENDENCIES_3)
 DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
 depcomp = $(SHELL) $(top_srcdir)/depcomp
 am__depfiles_maybe = depfiles
@@ -452,25 +453,17 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    $(FFTW3F_CFLAGS)
 
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 
 # This is a dependency for many swig operations
 GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
+# How to link in the USRP library from inside the tree
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
-
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
@@ -490,7 +483,7 @@ TESTS = test_all
 EXTRA_DIST = \
        test_buffers.py
 
-LIBGNURADIO = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
+LIBGNURADIO = $(GNURADIO_CORE_LA)
 LIBGNURADIOQA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core-qa.la $(LIBGNURADIO)
 benchmark_dotprod_SOURCES = benchmark_dotprod.cc
 benchmark_dotprod_LDADD = $(LIBGNURADIO)