Imported Upstream version 3.0.4
[debian/gnuradio] / gnuradio-core / src / lib / swig / Makefile.in
index 1da6e2f89d8b64ce31ce90614428c7e033a348c1..cffaac4450bf7969527332eafa02050a409dbb06 100644 (file)
@@ -21,7 +21,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -87,7 +87,7 @@ DIST_COMMON = $(grgrpython_PYTHON) $(grinclude_HEADERS) \
 subdir = gnuradio-core/src/lib/swig
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
 am__aclocal_m4_deps = $(top_srcdir)/config/acx_pthread.m4 \
-       $(top_srcdir)/config/cppunit.m4 $(top_srcdir)/config/gr_as.m4 \
+       $(top_srcdir)/config/cppunit.m4 \
        $(top_srcdir)/config/gr_boost.m4 \
        $(top_srcdir)/config/gr_check_createfilemapping.m4 \
        $(top_srcdir)/config/gr_check_shm_open.m4 \
@@ -145,10 +145,11 @@ am__installdirs = "$(DESTDIR)$(grgrlibdir)" \
        "$(DESTDIR)$(swigincludedir)"
 grgrlibLTLIBRARIES_INSTALL = $(INSTALL)
 LTLIBRARIES = $(grgrlib_LTLIBRARIES)
-am__DEPENDENCIES_1 =
-_gnuradio_swig_python_la_DEPENDENCIES =  \
-       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la \
-       $(am__DEPENDENCIES_1)
+am__DEPENDENCIES_1 =  \
+       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
+am__DEPENDENCIES_2 =
+_gnuradio_swig_python_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+       $(am__DEPENDENCIES_2)
 am__gnuradio_swig_python_la_OBJECTS = gnuradio_swig_python.lo
 _gnuradio_swig_python_la_OBJECTS =  \
        $(am__gnuradio_swig_python_la_OBJECTS)
@@ -409,25 +410,17 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    $(FFTW3F_CFLAGS)
 
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 
 # This is a dependency for many swig operations
 GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
+# How to link in the USRP library from inside the tree
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
-
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
@@ -472,7 +465,7 @@ _gnuradio_swig_python_la_SOURCES = \
        gnuradio_swig_python.cc         
 
 _gnuradio_swig_python_la_LIBADD = \
-       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la       \
+       $(GNURADIO_CORE_LA)                             \
        $(PYTHON_LDFLAGS)                               \
        -lstdc++
 
@@ -853,7 +846,7 @@ gnuradio_swig_python.cc : gnuradio.i
        else rm -f gnuradio_swig_python.Td; exit 1; fi 
 
 gnuradio_swig_bug_workaround.h : gnuradio_swig_python.cc $(srcdir)/gen-swig-bug-fix
-       $(srcdir)/gen-swig-bug-fix gnuradio_swig_python.cc $@
+       $(PYTHON) $(srcdir)/gen-swig-bug-fix gnuradio_swig_python.cc $@
 
 # ----------------------------------------------------------------