Imported Upstream version 3.0.4
[debian/gnuradio] / gnuradio-core / src / lib / swig / Makefile.am
index 590b07b856508113c90ad18df6ff2a71885df32f..f8d9297e69eb4e810ee07d5c47b6483963a27757 100644 (file)
@@ -5,7 +5,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -68,7 +68,7 @@ _gnuradio_swig_python_la_SOURCES =                    \
 
 
 _gnuradio_swig_python_la_LIBADD  =                     \
-       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la       \
+       $(GNURADIO_CORE_LA)                             \
        $(PYTHON_LDFLAGS)                               \
        -lstdc++
 
@@ -91,7 +91,7 @@ gnuradio_swig_python.cc : gnuradio.i
 
 
 gnuradio_swig_bug_workaround.h : gnuradio_swig_python.cc $(srcdir)/gen-swig-bug-fix
-       $(srcdir)/gen-swig-bug-fix gnuradio_swig_python.cc $@
+       $(PYTHON) $(srcdir)/gen-swig-bug-fix gnuradio_swig_python.cc $@
 
 
 # ----------------------------------------------------------------