Imported Debian patch 1.2.17rel-2
[debian/mtx] / debian / rules
index a6b3ef8c4ca9505885073c6e98666b88a56fc146..2284114d2068522208aefad5ca66106d094dbfbe 100755 (executable)
@@ -2,11 +2,7 @@
 # Sample debian/rules that uses debhelper.
 # GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
-export DH_COMPAT=3
+export DH_VERBOSE=1
 
 configure: configure-stamp
 configure-stamp:
@@ -26,6 +22,12 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
        -$(MAKE) distclean
+
+       -test -r /usr/share/misc/config.sub && \
+               cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && \
+               cp -f /usr/share/misc/config.guess config.guess
+
        dh_clean
 
 install: build
@@ -36,6 +38,8 @@ install: build
 
        make install bindir=`pwd`/debian/mtx/bin prefix=`pwd`/debian/mtx/usr \
                mandir=`pwd`/debian/mtx/usr/share/man
+       install -o root -g root -m 0644 debian/bash_completion \
+               debian/mtx/etc/bash_completion.d/mtx
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -48,7 +52,7 @@ binary-arch: build install
        dh_installexamples contrib/*
        dh_installmenu
        dh_installcron
-       dh_installman
+#      dh_installman
        dh_installinfo
        dh_installchangelogs CHANGES
        dh_link