Adding equiripple band reject filter to filter design app.
[debian/gnuradio] / configure.ac
index 5be42eb607bfddb5ddd0005c4380cdf95002f55f..25b1830277ba115f811d7c780e671ff41883d741 100644 (file)
@@ -26,7 +26,10 @@ AC_CANONICAL_BUILD
 AC_CANONICAL_HOST
 AC_CANONICAL_TARGET
 
-AM_INIT_AUTOMAKE(gnuradio,3.3svn)
+
+VERSION=3.3svn
+AC_SUBST(VERSION)
+AM_INIT_AUTOMAKE(gnuradio,$VERSION)
 
 DEFINES=""
 AC_SUBST(DEFINES)
@@ -286,6 +289,24 @@ dnl AX_BOOST_WSERIALIZATION
 
 dnl If this is being done from a subversion tree, create variables
 GR_SUBVERSION
+BUILD_DATE=`date -R -u`
+AC_SUBST(BUILD_DATE)
+
+dnl SYSCONFDIR substitution
+if test "${sysconfdir}" == "\${prefix}/etc" ; then
+   if test "${prefix}" == "NONE" ; then
+      SYSCONFDIR=["$ac_default_prefix/etc"]
+   else
+      SYSCONFDIR=["${prefix}/etc"]
+   fi
+else
+   SYSCONFDIR=[${sysconfdir}]
+fi
+AC_SUBST(SYSCONFDIR)
+
+dnl System configuration files
+GR_PREFSDIR=[$SYSCONFDIR/${PACKAGE}/conf.d]
+AC_SUBST(GR_PREFSDIR)
 
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
@@ -314,8 +335,7 @@ GRC_GRUEL                       dnl must come first
 GRC_OMNITHREAD                 dnl must come before gnuradio-core and mblock
 GRC_GCELL
 GRC_GNURADIO_CORE
-GRC_PMT
-GRC_MBLOCK                     dnl this must come after GRC_PMT
+GRC_MBLOCK                     dnl this must come after GRC_GRUEL
 GRC_USRP
 GRC_USRP2
 GRC_GR_USRP                    dnl this must come after GRC_USRP
@@ -372,6 +392,7 @@ AC_CONFIG_FILES([\
     Makefile \
     run_tests.sh \
     config/Makefile \
+    debian/changelog \
 ])
 
 dnl run_tests.sh is created from run_tests.sh.in .  Make it executable.