build: refactor GR_GIT and GR_VERSION
[debian/gnuradio] / config / grc_gruel.m4
index 0ef2bac2cdad6b0bdbc4a4e8d6301257b247a1ea..d8ac95fed63265dd3fa7a11b3e0f49a0cb14f615 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2009 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -25,10 +25,17 @@ AC_DEFUN([GRC_GRUEL],[
     dnl   with : if the --with code didn't error out
     dnl   yes  : if the --enable code passed muster and all dependencies are met
     dnl   no   : otherwise
+    if test $passed = yes; then
+       dnl Don't do gruel if guile not available
+       GRC_CHECK_GUILE(gruel)
+    fi
     if test $passed != with; then
-       dnl how and where to find INCLUDES and LA
-       gruel_INCLUDES="-I\${abs_top_srcdir}/gruel/src/include"
+       dnl how and where to find INCLUDES and LA and such
+       gruel_INCLUDES="\
+-I\${abs_top_srcdir}/gruel/src/include \
+-I\${abs_top_builddir}/gruel/src/include"
         gruel_LA="\${abs_top_builddir}/gruel/src/lib/libgruel.la"
+       gruel_LIBDIRPATH="\${abs_top_builddir}/gruel/src/lib:\${abs_top_builddir}/gruel/src/lib/.libs"
     fi
 
     AC_CONFIG_FILES([\
@@ -39,6 +46,10 @@ AC_DEFUN([GRC_GRUEL],[
         gruel/src/include/gruel/Makefile \
        gruel/src/include/gruel/inet.h \
         gruel/src/lib/Makefile \
+       gruel/src/lib/pmt/Makefile \
+       gruel/src/lib/msg/Makefile \
+       gruel/src/scheme/Makefile \
+       gruel/src/scheme/gnuradio/Makefile \
     ])
 
     dnl Allow creating autoconf independent header files for bytesex routines