build: force use of ltmain.sh from libtool 2.2.6b
[debian/gnuradio] / config / grc_gr_wxgui.m4
index 522c62520e6e419db6299d7feeb5b3c04d514389..c443f7c6c2f3826631a00458a989fed29c633c0e 100644 (file)
@@ -19,7 +19,6 @@ dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_WXGUI],[
     GRC_ENABLE(gr-wxgui)
-
     GRC_WITH(gr-wxgui)
 
     dnl Don't do gr-wxgui if gnuradio-core skipped
@@ -30,10 +29,8 @@ AC_DEFUN([GRC_GR_WXGUI],[
     dnl   yes  : if the --enable code passed muster and all dependencies are met
     dnl   no   : otherwise
     if test $passed = yes; then
-        dnl Don't do gr-wxgui if wxPython is not available
-        if ! ${PYTHON} -c 'import wx'; then
-            passed=no
-        fi
+        PYTHON_CHECK_MODULE([wx],[Python wxWidgets wrappers >= 2.8],[],[passed=no],[wx.version().split()[[0]] >= "2.8"])
+        PYTHON_CHECK_MODULE([numpy],[Numeric Python extensions],[],[passed=no])
     fi
 
     AC_CONFIG_FILES([ \
@@ -41,6 +38,7 @@ AC_DEFUN([GRC_GR_WXGUI],[
         gr-wxgui/gr-wxgui.pc \
         gr-wxgui/src/Makefile \
         gr-wxgui/src/python/Makefile \
+        gr-wxgui/src/python/plotter/Makefile \
     ])
 
     GRC_BUILD_CONDITIONAL(gr-wxgui)