build: force use of ltmain.sh from libtool 2.2.6b
[debian/gnuradio] / config / grc_gr_wxgui.m4
index 476c431d2ca41987b6d6a90ccef9b481e41d1e00..c443f7c6c2f3826631a00458a989fed29c633c0e 100644 (file)
@@ -29,14 +29,8 @@ AC_DEFUN([GRC_GR_WXGUI],[
     dnl   yes  : if the --enable code passed muster and all dependencies are met
     dnl   no   : otherwise
     if test $passed = yes; then
-        if ! ${PYTHON} -c 'import wx'; then
-            AC_MSG_RESULT([gr-wxgui requires wxPython, not found.])
-            passed=no
-        fi
-        if ! ${PYTHON} -c 'import numpy'; then
-            AC_MSG_RESULT([gr-wxgui requires numpy (Numeric Python), not found.])
-            passed=no
-        fi
+        PYTHON_CHECK_MODULE([wx],[Python wxWidgets wrappers >= 2.8],[],[passed=no],[wx.version().split()[[0]] >= "2.8"])
+        PYTHON_CHECK_MODULE([numpy],[Numeric Python extensions],[],[passed=no])
     fi
 
     AC_CONFIG_FILES([ \
@@ -44,7 +38,7 @@ AC_DEFUN([GRC_GR_WXGUI],[
         gr-wxgui/gr-wxgui.pc \
         gr-wxgui/src/Makefile \
         gr-wxgui/src/python/Makefile \
-       gr-wxgui/src/python/plotter/Makefile \
+        gr-wxgui/src/python/plotter/Makefile \
     ])
 
     GRC_BUILD_CONDITIONAL(gr-wxgui)