add Vcs entries to control file
[debian/gnuradio] / config / grc_gr_wxgui.m4
index f3104a37e36f67f3d3bf924101ebfe55b17f7589..c443f7c6c2f3826631a00458a989fed29c633c0e 100644 (file)
@@ -18,37 +18,28 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_WXGUI],[
-    GRC_ENABLE([gr-wxgui])
-    GRC_WITH([gr-wxgui])
-    passed=no
-    if test x$with_gr_wxgui = xyes; then
-        if test x$enable_gr_wxgui = xyes; then
-           AC_MSG_ERROR([Component gr-wxgui: Cannot use both --enable and --with])
-        else
-           PKG_CHECK_MODULES(GR_WXGUI, gr-wxgui, passed=with,
-                  AC_MSG_RESULT([Component gr-wxgui: PKGCONFIG cannot find info]))
-       fi
-    fi
-    dnl if $passed = with, then "--with" worked; ignore the "--enable" stuff
-    dnl otherwise, $passed = no; check the "--enable" stuff
-    if test x$passed = xno; then
-        AC_CONFIG_FILES([ \
-           gr-wxgui/Makefile \
-           gr-wxgui/gr-wxgui.pc \
-           gr-wxgui/src/Makefile \
-           gr-wxgui/src/python/Makefile \
-        ])
+    GRC_ENABLE(gr-wxgui)
+    GRC_WITH(gr-wxgui)
+
+    dnl Don't do gr-wxgui if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-wxgui, gnuradio-core)
 
-        passed=yes
-        # Don't do gr-wxgui if gnuradio-core skipped
-        if test x$gnuradio_core_skipped = xyes; then
-            AC_MSG_RESULT([Component gr-wxgui requires gnuradio-core, which is not being built or specified via pre-installed files.])
-            passed=no
-        fi
-        # Don't do gr-wxgui if wxPython is not available
-        if ! ${PYTHON} -c 'import wx'; then
-            passed=no
-        fi
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        PYTHON_CHECK_MODULE([wx],[Python wxWidgets wrappers >= 2.8],[],[passed=no],[wx.version().split()[[0]] >= "2.8"])
+        PYTHON_CHECK_MODULE([numpy],[Numeric Python extensions],[],[passed=no])
     fi
-    GRC_BUILD_CONDITIONAL([gr-wxgui])
+
+    AC_CONFIG_FILES([ \
+        gr-wxgui/Makefile \
+        gr-wxgui/gr-wxgui.pc \
+        gr-wxgui/src/Makefile \
+        gr-wxgui/src/python/Makefile \
+        gr-wxgui/src/python/plotter/Makefile \
+    ])
+
+    GRC_BUILD_CONDITIONAL(gr-wxgui)
 ])