add Vcs entries to control file
[debian/gnuradio] / config / grc_gr_wxgui.m4
index 8f3c8f8ee9ea3b3bd344e029a0e0f2bc1ec59045..c443f7c6c2f3826631a00458a989fed29c633c0e 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,20 +14,32 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_WXGUI],[
-    AC_CONFIG_SRCDIR([gr-wxgui/src/python/stdgui.py])
+    GRC_ENABLE(gr-wxgui)
+    GRC_WITH(gr-wxgui)
 
-    # FIXME: Should we actually check for wxPython, even though
-    # this is a runtime requirement, not a compile/install time one?
+    dnl Don't do gr-wxgui if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-wxgui, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        PYTHON_CHECK_MODULE([wx],[Python wxWidgets wrappers >= 2.8],[],[passed=no],[wx.version().split()[[0]] >= "2.8"])
+        PYTHON_CHECK_MODULE([numpy],[Numeric Python extensions],[],[passed=no])
+    fi
 
     AC_CONFIG_FILES([ \
-         gr-wxgui/Makefile \
-         gr-wxgui/src/Makefile \
-         gr-wxgui/src/python/Makefile \
+        gr-wxgui/Makefile \
+        gr-wxgui/gr-wxgui.pc \
+        gr-wxgui/src/Makefile \
+        gr-wxgui/src/python/Makefile \
+        gr-wxgui/src/python/plotter/Makefile \
     ])
 
-    subdirs="$subdirs gr-wxgui"
+    GRC_BUILD_CONDITIONAL(gr-wxgui)
 ])