Add gru.hexshort to deal with short hex constants
[debian/gnuradio] / config / grc_gr_video_sdl.m4
index c161b5f3e84ff69aeafda47dc78f22d6cc7eec67..c890bc31c452a4483055791714f6249498bc7b57 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2009 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,30 +14,36 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_VIDEO_SDL],[
-    AC_CONFIG_SRCDIR([gr-video-sdl/src/video_sdl.i])
+    GRC_ENABLE([gr-video-sdl])
+
+    dnl Don't do gr-video-sdl if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-video-sdl, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-video-sdl if the SDL library is unavailable.
+       PKG_CHECK_MODULES(SDL, sdl >= 1.2.0, [],
+          [SDL_VERSION=1.2.0
+           AM_PATH_SDL($SDL_VERSION, [], [
+             passed=no;AC_MSG_RESULT([gr-video-sdl requires library sdl, not found or failed test.])])])
+    fi
 
     AC_CONFIG_FILES([ \
-       gr-video-sdl/Makefile \
-       gr-video-sdl/src/Makefile \
-       gr-video-sdl/src/run_tests \
+        gr-video-sdl/Makefile \
+       gr-video-sdl/gnuradio-video-sdl.pc \
+        gr-video-sdl/src/Makefile \
+        gr-video-sdl/src/run_tests \
     ])
-    
-    succeeded=yes
-    dnl Check for SDL
-    SDL_VERSION=1.2.0
-    AM_PATH_SDL($SDL_VERSION,[],[succeeded=no])
 
-    if test $succeeded = yes; then
-        AM_CFLAGS="$AM_CFLAGS $SDL_CFLAGS"
-        AM_LDFLAGS="$AM_LDFLAGS $SDL_LIBS"
+    GRC_BUILD_CONDITIONAL(gr-video-sdl,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_sdl], [chmod +x gr-video-sdl/src/run_tests])
-        subdirs="$subdirs gr-video-sdl"
-    else
-       failed="$failed gr-video-sdl"
-    fi
+    ])
 ])