Fixing benchmark program to work with original dbpsk/dqpsk modulations again (and...
[debian/gnuradio] / config / grc_gr_radio_astronomy.m4
index cc966295b19c7efd7313b64692ed82241413d2ee..0affe5d7856b380a81263b2ec9b3a030689c5246 100644 (file)
@@ -18,24 +18,20 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_RADIO_ASTRONOMY],[
-    GRC_ENABLE([gr-radio-astronomy])
+    GRC_ENABLE(gr-radio-astronomy)
+
+    dnl Don't do gr-radio-astronomy if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-radio-astronomy, gnuradio-core)
 
     AC_CONFIG_FILES([\
-       gr-radio-astronomy/Makefile \
-       gr-radio-astronomy/src/Makefile \
-       gr-radio-astronomy/src/lib/Makefile \
-       gr-radio-astronomy/src/python/Makefile \
-       gr-radio-astronomy/src/python/run_tests \
+        gr-radio-astronomy/Makefile \
+        gr-radio-astronomy/src/Makefile \
+        gr-radio-astronomy/src/lib/Makefile \
+        gr-radio-astronomy/src/python/Makefile \
+        gr-radio-astronomy/src/python/run_tests \
     ])
 
-    passed=yes
-    # Don't do gr-radio-astronomy if gnuradio-core skipped
-    if test x$gnuradio_core_skipped = xyes; then
-        AC_MSG_RESULT([Component gr-radio-astronomy requires gnuradio-core, which is not being built or specified via pre-installed files.])
-       passed=no
-    fi
-
-    GRC_BUILD_CONDITIONAL([gr-radio-astronomy],[
+    GRC_BUILD_CONDITIONAL(gr-radio-astronomy,[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_astronomy], [chmod +x gr-radio-astronomy/src/python/run_tests])
     ])