Fixing benchmark program to work with original dbpsk/dqpsk modulations again (and...
[debian/gnuradio] / config / grc_gr_radio_astronomy.m4
index 0b445dbcbf58e4e32ad468051a4487774bdd52df..0affe5d7856b380a81263b2ec9b3a030689c5246 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,22 +14,25 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_RADIO_ASTRONOMY],[
-    AC_CONFIG_SRCDIR([gr-radio-astronomy/src/lib/ra.i])
+    GRC_ENABLE(gr-radio-astronomy)
+
+    dnl Don't do gr-radio-astronomy if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-radio-astronomy, gnuradio-core)
 
     AC_CONFIG_FILES([\
-       gr-radio-astronomy/Makefile \
-       gr-radio-astronomy/src/Makefile \
-       gr-radio-astronomy/src/lib/Makefile \
-       gr-radio-astronomy/src/python/Makefile \
-       gr-radio-astronomy/src/python/run_tests \
+        gr-radio-astronomy/Makefile \
+        gr-radio-astronomy/src/Makefile \
+        gr-radio-astronomy/src/lib/Makefile \
+        gr-radio-astronomy/src/python/Makefile \
+        gr-radio-astronomy/src/python/run_tests \
     ])
 
-    dnl run_tests is created from run_tests.in.  Make it executable.
-    AC_CONFIG_COMMANDS([run_tests_astronomy], [chmod +x gr-radio-astronomy/src/python/run_tests])
-
-    subdirs="$subdirs gr-radio-astronomy"
+    GRC_BUILD_CONDITIONAL(gr-radio-astronomy,[
+        dnl run_tests is created from run_tests.in.  Make it executable.
+        AC_CONFIG_COMMANDS([run_tests_astronomy], [chmod +x gr-radio-astronomy/src/python/run_tests])
+    ])
 ])