Defend against a peer that sends an invalid message length.
[debian/gnuradio] / config / grc_gr_pager.m4
index 2c859ee627fee7fe2b089fa4a15faf1fa9bf4985..cdd6177af1f17fee05e21ca9ecd6698afa9fb4f9 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2006,2008,2009 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,21 +14,28 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_PAGER],[
-    GRC_ENABLE([gr-pager])
+    GRC_ENABLE(gr-pager)
+
+    dnl Don't do gr-pager if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-pager, gnuradio-core)
 
     AC_CONFIG_FILES([\
-       gr-pager/Makefile \
-       gr-pager/src/Makefile \
-       gr-pager/src/run_tests
+        gr-pager/Makefile \
+       gr-pager/gnuradio-pager.pc \
+       gr-pager/apps/Makefile \
+       gr-pager/grc/Makefile \
+        gr-pager/lib/Makefile \
+       gr-pager/python/Makefile \
+       gr-pager/python/run_tests \
+       gr-pager/swig/Makefile \
     ])
 
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-pager],[
+    GRC_BUILD_CONDITIONAL(gr-pager,[
         dnl run_tests is created from run_tests.in.  Make it executable.
-        AC_CONFIG_COMMANDS([run_tests_pager], [chmod +x gr-pager/src/run_tests])
+        AC_CONFIG_COMMANDS([run_tests_pager], [chmod +x gr-pager/python/run_tests])
     ])
 ])