Minor cleanups.
[debian/gnuradio] / config / grc_gr_gsm_fr_vocoder.m4
index 3d99fb51d7fe829bd9f7ad55c87ac96ac573b455..a93d4edb7e13be4c80bd5b3d15a3bf6d105d7614 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,23 +14,26 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_GSM_FR_VOCODER],[
-    GRC_ENABLE([gr-gsm-fr-vocoder])
+    GRC_ENABLE(gr-gsm-fr-vocoder)
+
+    dnl Don't do gr-gsm-fr-vocoder if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-gsm-fr-vocoder, gnuradio-core)
 
     AC_CONFIG_FILES([\
-       gr-gsm-fr-vocoder/Makefile \
-       gr-gsm-fr-vocoder/src/Makefile \
-       gr-gsm-fr-vocoder/src/lib/Makefile \
-       gr-gsm-fr-vocoder/src/lib/gsm/Makefile \
-       gr-gsm-fr-vocoder/src/python/Makefile \
-       gr-gsm-fr-vocoder/src/python/run_tests \
+        gr-gsm-fr-vocoder/Makefile \
+       gr-gsm-fr-vocoder/gnuradio-gsm-fr-vocoder.pc \
+        gr-gsm-fr-vocoder/src/Makefile \
+        gr-gsm-fr-vocoder/src/lib/Makefile \
+        gr-gsm-fr-vocoder/src/lib/gsm/Makefile \
+        gr-gsm-fr-vocoder/src/python/Makefile \
+        gr-gsm-fr-vocoder/src/python/run_tests \
     ])
 
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-gsm-fr-vocoder],[
+    GRC_BUILD_CONDITIONAL(gr-gsm-fr-vocoder,[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_gsm], [chmod +x gr-gsm-fr-vocoder/src/python/run_tests])
     ])