Update revision to release 3.3.0-rc1, update autotools
[debian/gnuradio] / config / grc_gr_cvsd_vocoder.m4
index a4f9578e5649780e5817ecf66c3aaf29afb4dc91..ddf6f9b2f2b72fd6d8ebc8c636e79a84ac1274f4 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,18 +18,21 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_CVSD_VOCODER],[
-    GRC_ENABLE([gr-cvsd-vocoder])
+    GRC_ENABLE(gr-cvsd-vocoder)
+
+    dnl Don't do gr-cvsd-vocoder if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-cvsd-vocoder, gnuradio-core)
 
     AC_CONFIG_FILES([\
-       gr-cvsd-vocoder/Makefile \
-       gr-cvsd-vocoder/src/Makefile \
-       gr-cvsd-vocoder/src/lib/Makefile \
-       gr-cvsd-vocoder/src/python/Makefile \
-       gr-cvsd-vocoder/src/python/run_tests \
+        gr-cvsd-vocoder/Makefile \
+       gr-cvsd-vocoder/gnuradio-cvsd-vocoder.pc \
+        gr-cvsd-vocoder/src/Makefile \
+        gr-cvsd-vocoder/src/lib/Makefile \
+        gr-cvsd-vocoder/src/python/Makefile \
+        gr-cvsd-vocoder/src/python/run_tests \
     ])
 
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-cvsd-vocoder],[
+    GRC_BUILD_CONDITIONAL(gr-cvsd-vocoder,[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_cvsd], [chmod +x gr-cvsd-vocoder/src/python/run_tests])
     ])