Change default bandwidth to 25 MHz to match maximum USRP2 bandwidth
[debian/gnuradio] / config / grc_gr_comedi.m4
index b27b7d70a524697d20cbea02efd446834dfd6e34..5e30894174b46c697e416dec7c2ae2b1d8e8ab66 100644 (file)
@@ -18,26 +18,29 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_COMEDI],[
-    GRC_ENABLE([gr-comedi])
+    GRC_ENABLE(gr-comedi)
 
-    AC_CONFIG_FILES([ \
-       gr-comedi/Makefile \
-       gr-comedi/src/Makefile \
-       gr-comedi/src/run_tests \
-    ])
+    dnl Don't do gr-comedi if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-comedi, gnuradio-core)
 
-    passed=yes
-    # Don't do gr-comedi if gnuradio-core skipped
-    if test x$gnuradio_core_skipped = xyes; then
-        AC_MSG_RESULT([Component gr-comedi requires gnuradio-core, which is not being built or specified via pre-installed files.])
-       passed=no
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-comedi if the 'comedi' library is unavailable.
+        PKG_CHECK_MODULES(COMEDI, comedilib < 0.8,[],
+            [passed=no;AC_MSG_RESULT([gr-comedi requires comedilib, not found.])])
     fi
-    # Don't do gr-comedi if the 'comedi' library is unavailable.
-    PKG_CHECK_MODULES(COMEDI, comedilib >= 0.7,[],
-        [passed=no;AC_MSG_RESULT([gr-comedi requires comedilib, not found.])])
 
-    GRC_BUILD_CONDITIONAL([gr-comedi],[
-       AC_SUBST(COMEDI_LIBS)
+    AC_CONFIG_FILES([ \
+        gr-comedi/Makefile \
+       gr-comedi/gnuradio-comedi.pc \
+        gr-comedi/src/Makefile \
+        gr-comedi/src/run_tests \
+    ])
+
+    GRC_BUILD_CONDITIONAL(gr-comedi,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_comedi], [chmod +x gr-comedi/src/run_tests])
     ])