Change default bandwidth to 25 MHz to match maximum USRP2 bandwidth
[debian/gnuradio] / config / grc_gr_comedi.m4
index 0800bdec630e429e890bbe9dbee7876a8349ec74..5e30894174b46c697e416dec7c2ae2b1d8e8ab66 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,28 +14,34 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_COMEDI],[
-    AC_CONFIG_SRCDIR([gr-comedi/src/comedi.i])
+    GRC_ENABLE(gr-comedi)
+
+    dnl Don't do gr-comedi if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-comedi, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-comedi if the 'comedi' library is unavailable.
+        PKG_CHECK_MODULES(COMEDI, comedilib < 0.8,[],
+            [passed=no;AC_MSG_RESULT([gr-comedi requires comedilib, not found.])])
+    fi
 
     AC_CONFIG_FILES([ \
-       gr-comedi/Makefile \
-       gr-comedi/src/Makefile \
-       gr-comedi/src/run_tests \
+        gr-comedi/Makefile \
+       gr-comedi/gnuradio-comedi.pc \
+        gr-comedi/src/Makefile \
+        gr-comedi/src/run_tests \
     ])
 
-    succeeded=yes
-    PKG_CHECK_MODULES(COMEDI, comedilib >= 0.7,[],[succeeded=no])
-    if test $succeeded = yes; then
-        LIBS="$LIBS $COMEDI_LIBS"
-
+    GRC_BUILD_CONDITIONAL(gr-comedi,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_comedi], [chmod +x gr-comedi/src/run_tests])
-        subdirs="$subdirs gr-comedi"
-    else
-       AC_MSG_WARN([$COMEDI_PKG_ERRORS])
-       failed="$failed gr-comedi"
-    fi
+    ])
 ])