Update revision to release 3.3.0-rc1, update autotools
[debian/gnuradio] / config / grc_gr_audio_osx.m4
index a42ecd5c5cda17b9650722948a17f2085b107509..df8634ff6fa352ce4b1b122e89bffec1fcfeb679 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2010 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -18,30 +18,35 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_OSX],[
-    GRC_ENABLE([gr-audio-osx])
+    GRC_ENABLE(gr-audio-osx)
 
-    AC_CONFIG_FILES([ \
-       gr-audio-osx/Makefile \
-       gr-audio-osx/src/Makefile \
-       gr-audio-osx/src/run_tests \
-    ])
+    dnl Don't do gr-audio-osx if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-osx, gnuradio-core)
 
-    passed=yes
-    MACOSX_AUDIOUNIT([],
-        [passed=no;AC_MSG_RESULT([gr-audio-osx requires AudioUnit, not found.])])
-
-    # Don't do gr-audio-osx if omnithread skipped
-    if test x$omnithread_skipped = xyes; then
-        AC_MSG_RESULT([Component gr-audio-osx requires omnithread, which is not being built or specified via pre-installed files.])
-       passed=no
-    fi
-    # Don't do gr-audio-osx if gnuradio-core skipped
-    if test x$gnuradio_core_skipped = xyes; then
-        AC_MSG_RESULT([Component gr-audio-osx requires gnuradio-core, which is not being built or specified via pre-installed files.])
-       passed=no
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        case "$host_os" in
+          darwin*)
+              MACOSX_AUDIOUNIT([],
+                  [passed=no;AC_MSG_RESULT([gr-audio-osx requires AudioUnit, not found.])])
+              ;;
+          *)
+              AC_MSG_RESULT([gr-audio-osx will build on Mac OS X and Darwin only.])
+              passed=no
+              ;;
+        esac
     fi
 
-    GRC_BUILD_CONDITIONAL([gr-audio-osx],[
+    AC_CONFIG_FILES([ \
+        gr-audio-osx/Makefile \
+        gr-audio-osx/src/Makefile \
+        gr-audio-osx/src/run_tests \
+    ])
+
+    GRC_BUILD_CONDITIONAL(gr-audio-osx,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_osx], [chmod +x gr-audio-osx/src/run_tests])
     ])